Tupale

no funciona la pagina usuarios.php

Inicio Foros Desarrollo Web no funciona la pagina usuarios.php

Etiquetado: , ,

Este debate contiene 1 respuesta, tiene 2 mensajes y lo actualizó  kalvinmanson hace 3 años, 4 meses.

Viendo 2 publicaciones - del 1 al 2 (de un total de 2)
  • Autor
    Publicaciones
  • #1471
    Imagen de perfil de victor
    victor
    Participant
    < ?php virtual(‘/adolecentes/Connections/adolecente.php’); ?>
    < ?php
    if (!function_exists("GetSQLValueString")) {
    function GetSQLValueString($theValue, $theType, $theDefinedValue = "", $theNotDefinedValue = "")
    {
    if (PHP_VERSION < 6) {
    $theValue = get_magic_quotes_gpc() ? stripslashes($theValue) : $theValue;
    }
    
    $theValue = function_exists("mysql_real_escape_string") ? mysql_real_escape_string($theValue) : mysql_escape_string($theValue);
    
    switch ($theType) {
    case "text":
    $theValue = ($theValue != "") ? "‘" . $theValue . "‘" : "NULL";
    break;
    case "long":
    case "int":
    $theValue = ($theValue != "") ? intval($theValue) : "NULL";
    break;
    case "double":
    $theValue = ($theValue != "") ? doubleval($theValue) : "NULL";
    break;
    case "date":
    $theValue = ($theValue != "") ? "‘" . $theValue . "‘" : "NULL";
    break;
    case "defined":
    $theValue = ($theValue != "") ? $theDefinedValue : $theNotDefinedValue;
    break;
    }
    return $theValue;
    }
    }
    ?>
    < ?php
    // *** Validate request to login to this site.
    if (!isset($_SESSION)) {
    session_start();
    }
    
    $loginFormAction = $_SERVER['PHP_SELF'];
    if (isset($_GET['accesscheck'])) {
    $_SESSION['PrevUrl'] = $_GET['accesscheck'];
    }
    
    if (isset($_POST['usu'])) {
    $loginUsername=$_POST['usu'];
    $password=$_POST['psw'];
    $MM_fldUserAuthorization = "id_rol";
    $MM_redirectLoginSuccess = "/adolecentes/HTML/Administrador/index.html";
    $MM_redirectLoginFailed = "/adolecentes/HTML/usuarios.php";
    $MM_redirecttoReferrer = false;
    mysql_select_db($database_adolecente, $adolecente);
    
    $LoginRS__query=sprintf("SELECT usuario, contrasena, id_rol FROM usuarios WHERE usuario=%s AND contrasena=%s",
    GetSQLValueString($loginUsername, "text"), GetSQLValueString($password, "text"));
    
    $LoginRS = mysql_query($LoginRS__query, $adolecente) or die(mysql_error());
    $loginFoundUser = mysql_num_rows($LoginRS);
    if ($loginFoundUser) {
    
    $loginStrGroup = mysql_result($LoginRS,0,’id_rol’);
    
    //declare two session variables and assign them
    $_SESSION['MM_Username'] = $loginUsername;
    $_SESSION['MM_UserGroup'] = $loginStrGroup;
    
    if (isset($_SESSION['PrevUrl']) && false) {
    $MM_redirectLoginSuccess = $_SESSION['PrevUrl'];
    }
    header("Location: " . $MM_redirectLoginSuccess );
    }
    else {
    header("Location: ". $MM_redirectLoginFailed );
    }
    }
    ?>
    < ?php
    
    .....
    
    • Este debate fue modificado hace 3 años, 4 meses por  kalvinmanson.
    • Este debate fue modificado hace 3 años, 4 meses por  kalvinmanson.
    #1473

    kalvinmanson
    Keymaster

    Creo que tu problema es principalmente esto

    < ?php

    las etiquetas

    < ?php ?>

    se usan unicamente para poner el codigo PHP, el codigo HTML ponlo por fuera del codigo PHP, si quieres mostrar codigo HTML desde PHP puedes hacerlo asi

     < ?php echo ''; ?>
    

    Siempre teniendo presente el escapar correctamente las comillas.

Viendo 2 publicaciones - del 1 al 2 (de un total de 2)

Debes estar registrado para responder a este debate.